Rally unresponsive pages when adding new child items
Incident Report for Rally Software
Resolved
This incident has been resolved.
Posted Apr 07, 2021 - 16:15 UTC
Monitoring
As of 3:13 PM UTC, the issue experienced by some customers has been addressed and functionality has been restored. We are currently monitoring the performance closely.

Please perform a hard refresh on any pages that were experiencing difficulties (typically Shift + Refresh), or clear your browser cache to ensure you have the most recent changes.

The next update will be provided as new information is available.
Posted Apr 07, 2021 - 15:13 UTC
Identified
The issue has been identified and a fix is being implemented.
Posted Apr 07, 2021 - 14:49 UTC
Investigating
We are aware of some customers experiencing unresponsive pages when adding child items. We are currently investigating the cause of this issue and will provide updates as new information becomes available.

As a workaround, it is possible to switch to the quick detail page which shows as a pane on the right side of the browser instead of using full-screen editing mode.

All other aspects of the product are functioning as normal.
Posted Apr 07, 2021 - 14:18 UTC
This incident affected: US (Main Application).