Rally is currently down
Incident Report for Rally Software
Resolved
As of 9:07 Mountain Time, the issue experienced by customers has been addressed and functionality has been restored. This incident is now resolved.
Posted Apr 30, 2021 - 15:09 UTC
Investigating
We are aware of some customers experiencing Rally down. We are currently investigating the cause of this issue and will provide updates as new information becomes available.

All other aspects of the product are functioning as normal.
Posted Apr 30, 2021 - 14:59 UTC
This incident affected: US (Authentication, Insights (Beta), Lookback API, Main Application, Support Link, Search, Watches).